안드로이드 스튜디오에서 sdk는 안드로이드 버전별로 전부 설치해야 하는건가요?

2019. 04. 14. 12:48

안녕하세요

webrtc를 통해 안드로이드 작업하려 합니다

4.4버전대(킷캣)와 7,8버전대(누가, 오레오)에서 앱이 작동되는것을 확인했는데,

유독 5.0버전대에서 문제가 생기더군요,

킷캣에서도 작동하고 오레오에서도 작동하니 중간버전대인 롤리팝에서도 잘 작동할줄 알았는데, 아니더라구요

빌드자체는 되고 기능상의 문제인데

혹시 sdk가 설치가 안되있으면 이러한 경우도 있나요?

그러면 버전별로 sdk를 모두 설치해 주어야 하는건가요?

공유하고 보상받기 ♥︎

총 1개의 답변이 있습니다.

질문자 채택 답변

5.0 버전대에서 문제가 발생하던 것이, 5.0 버전대 SDK를 설치했더니 해결됐나요??

컴파일 할 때 기준이 될 버전의 SDK만 설치되어 있어도 다른 버전도 문제 없이 동작합니다.

SDK 설치가 아니라, 다른 문제 해결이 필요할 것 같습니다.

2019. 04. 14. 14:12
150